Trailer Bad Rabits Tattoos


Trailer Bad Rabits Tattoos compatible with the game Euro Truck Simulator 2 in version 1.22 up to 1.26.x or higher and American Truck Simulator in version 1.4.4.2 and 1.5.X.X, this trailer is also compatible with the EAA map and Elite map of the Estradão.

Credits: Geovane Rocha e equipe LOG Holding, Ideia do FelipeeWenzel do canal no youtube FelipeeWenzel

DOWNLOAD

Leave a Reply